Forumsee logo
Forumsee » Motorbikes » Brands & Models » Read message
RSS: Subscribe to RSS

Sportycity One 125 starter won't even click after cleaning carb.

Aprilia and Piaggio 150cc-350cc - www.apriliaforum.com
The bike was in storage for a couple of months before I removed and cleaned the carb. I've cleaned carbs before, but only simple ones on mopeds, chainsaws, etc.. After putting the carb back on the bike, it won't start. Total silence. The battery seems fine, not even a click from the starter motor. Before I go testing everything, does anyone know of a common newbie mistake when putting a carb back on that would do this. I'm assuming it's a wiring issue of sorts. There's a bunch of things connected to the carb, way more than the simple ones I've worked on before. Checked all the harnesses, etc..


Read responses in apriliaforum.com

Tags


Last videos:

Super cool YouTube vids...
Super cool YouTube vids...
Fast Harley on The Snake
Fast Harley on The Snake
Sport Glide Saddlebag flaw
Sport Glide Saddlebag flaw
The TRUTH about new bike buyers
The TRUTH about new bike buyers
Videos with Aquatic AV installed
Videos with Aquatic AV installed
Backroading in florida
Backroading in florida
the end of Dynas ...
the end of Dynas ...
Found some 2018 Harley vids
Found some 2018 Harley vids
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more