Forumsee logo
Forumsee » Motorbikes » Brands & Models » Read message
RSS: Subscribe to RSS

Rough idle and lack of power

1200 GS Wasserhead - ::. UKGSer.com .:: - www.ukgser.com
Had a brilliant run out today bike r1200gs lc running great and no issues. I rode into a busy town and slow moving traffic and the idle felt rough and the warning triangle went to orange. I stopped bike turn ignition off then started bike again and warning light now off so I blasted it down motorway and it wouldn`t pull like it should as I geared down to 4th and went on full throttle just didnt pull at all well. I came off motorway to lights and idle was rough.

I have changed plugs tonight and air filter and disconnected battery hoping it was a software glitch but not been on it.

Anyone any ideas or advice?


Read responses in ukgser.com

Tags


Last videos:

Dr. Jeckyll and Mr. Hyde exhaust
Dr. Jeckyll and Mr. Hyde exhaust
My Youtube channel!
My Youtube channel!
Came Across This On YouTube...This Guy Is Hilarious
Came Across This On YouTube...This Guy Is Hilarious
Super cool YouTube vids...
Super cool YouTube vids...
Fast Harley on The Snake
Fast Harley on The Snake
Sport Glide Saddlebag flaw
Sport Glide Saddlebag flaw
The TRUTH about new bike buyers
The TRUTH about new bike buyers
Videos with Aquatic AV installed
Videos with Aquatic AV installed
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-backend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more