Forumsee logo
Forumsee » Motorbikes » Brands & Models » Read message
RSS: Subscribe to RSS

Fast Blinking Left Indicator

Parallel Universe - ADVrider - www.advrider.com
So a few weeks ago my warning light came on and my screen indicated "bulb". I quickly realized my front right blinker wasn't working, I have after market LED blinkers so I first hooked up the bulb to a battery and it worked. Played around with wiring, sprayed some WD-40 into the connection about a foot of wiring away from the indicator, problem solved.

Jump forward to yesterday, my "bulb" error comes up again but this time for the left side. I couldn't figure out why at first, then after stopping for a beer and initiating my left turn, nothing happened, no signals and no signal indicator on dash. Right turn signals worked great.

This morning I went to check on it again, left blinkers are now working but blinking fast. After some searches I found some people solved the issue by using grease on the ground wire. I feel it's likely this issue is related to my right blinker a few weeks ago but unsure. Any thoughts? (If I do need to grease ground, where can it be found?)

Also, both times this happened on hot days, no idea if that makes any difference.

2014 F800GSA


Read responses in advrider.com

Tags


Last videos:

Super cool YouTube vids...
Super cool YouTube vids...
Fast Harley on The Snake
Fast Harley on The Snake
Sport Glide Saddlebag flaw
Sport Glide Saddlebag flaw
The TRUTH about new bike buyers
The TRUTH about new bike buyers
Videos with Aquatic AV installed
Videos with Aquatic AV installed
Backroading in florida
Backroading in florida
the end of Dynas ...
the end of Dynas ...
Found some 2018 Harley vids
Found some 2018 Harley vids
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more